Back to overview
Resolved
Claim System Integration - Snapsheet
Jun 18, 2026 at 9:36pm UTC
Affected services
Kyber LetterGen Application
Resolved
Jun 18, 2026 at 9:36pm UTC
Snapsheet - Kyber Users are noticing degraded performance of Kyber when typing in a claim number and having data auto-populate into the system.
We are investigating this currently.
Affected services