Back to overview
Resolved

Service Provider Outage

Jun 18, 2026 at 9:47pm UTC
Affected services
Kyber LetterGen Application

Resolved
Jun 18, 2026 at 9:47pm UTC

A Third Party Service Provider responsible for handling API Calls is currently experiencing an outage.

Claims System Calls will be non-functional at this time. Sending a letter utilizing a send workflow that has a Claim System Integration, or otherwise, may also be degraded at this time.