Back to overview
Resolved
Third Party Service Provider - Continued Outage
Jun 19, 2026 at 4:26pm UTC
Affected services
Kyber LetterGen Application
Resolved
Jun 19, 2026 at 4:26pm UTC
We are continuing to see a current outage which is affecting AI Template usability directly, and other features in the product.
We believe to have found the root cause of the problem, and are working to remedy as soon as possible.
Affected services