Back to overview
Resolved

Kyber - Internal Services are Down

Aug 3, 2026 at 2:55pm UTC
Affected services
Kyber LetterGen Application

Resolved
Aug 3, 2026 at 2:55pm UTC

An Internal Services Provider (Cloudflare) responsible for hosting the Kyber Application is currently experiencing unscheduled downtime.

We are working to resolve this with them as quickly as possible.