Back to overview
Degraded
Email notifications unavailable
Sep 5, 2025 at 1:55pm UTC
Affected services
Kyber LetterGen Application
Resolved
Sep 5, 2025 at 4:00pm UTC
Fix by upstream provider is in place, service has been restored and email notifications are back in service.
Affected services
Created
Sep 5, 2025 at 1:55pm UTC
Upstream provider is having issues, root cause identified, working on a fix.
Affected services