Back to overview
Error when Clicking Letter - Something Went Wrong
Oct 21 at 01:50pm EDT
Affected services
Kyber LetterGen Application
Resolved
Oct 21 at 02:19pm EDT
We have resolved the previous issue regarding users and their ability to access letters within Kyber.
Affected services
Created
Oct 21 at 01:50pm EDT
We are aware of an issue that is stopping our users from being able to access letters in Kyber. We are currently working on a fix to restore usage and remedy the issue at this time.
Affected services